English Muffins! Dampfnudeln! SketchUp!

I’m glad I’m not working this week — I might not have had the pleasure of these several experiences  In reverse chronological order:

Thanks, Wikipedia!
Thanks, Wikipedia!
  1. I stumbled upon English Muffins at Edeka this afternoon! I’ve been looking for these puppies for like five years now. Maybe they were there the whole time and I’m just not a good finder (ask Sarah), but I prefer to believe that they’re new to the market (at least around here). Stocked up this afternoon, tried ’em out this evening with a little lemon curd spread over them and…yum!
  2. Dampfnudel Uli is one of those places I’ve been walking or biking past for about five years now and haven’t ever tried — though locals have recommended it to me on occasion. It’s literally a hole in the wall around the corner from L’Osteria tucked back in one of those Altstadt streets which are almost too narrow for my bike. Besides Dampfnudeln, they specialize in kitsch*. We should have figured this out from their odd hours: 10:01 to 15:01 weekdays (and they’re closed Sundays and Mondays). Sarah and I ducked in there on a whim today for dessert after a combined meter of sausage on this, the Weihnachtsmarkt’s final day. Results: mixed.
    • The coffee was dreadful.
    • The special of the day was OK, if a little weird. It was beer-battered Apfelkücherl in a Weißwein-Vanillesoße. I’m not sure how I felt about the vanilla pudding with a white wine aftertaste.
    • The Dampfnudeln in their own non-boozy Vanillasoße (on sale every day) were excellent.

    Just goes to show: go with what you know.

  3. Google SketchUp looked neat as all get out for 3D-diagramming — especially in the training videos. I’d heard Tammy was happy with Google SketchUp for layouting their furniture in their new apartment. Unfortunately, for diagramming ours, it’s not working out at all. Of course I looked for a Linux version first. No dice there. Then I tried installing it on the Windows machine at my disposal. It appears to install OK, but quickly crashes as soon as I try to launch the application. I got it installed easily on our Mac, but it’s a real pig to use (even after watching the nifty tutorials). It’s slow and jerky and every action (adding a new polygon, erasing an existing one) invokes the pinwheel and 10-15 seconds of waiting. Yuck. I know my Mac is weak*, but c’mon.

    Has anyone managed to get it to work?